Trong các bài viết trước, mình đã giới thiệu về VLAN, giao thức 802.1Q. Trong bài viết hôm nay ta sẽ đi tìm hiểu về đường hầm Q-IN-Q và cách nó hoạt động như thế nào?

Giới thiệu về Q-IN-Q

802.1Q Tunneling, hay còn được biết đến với tên gọi Q-in-Q, là một phương pháp được sử dụng trong mạng để tạo ra các kết nối ảo và truyền tải các giao dịch mạng VLAN qua một mạng VLAN khác. Đây là một phương pháp mở rộng của giao thức 802.1Q, mà thường được sử dụng để xác định các khối dữ liệu của mạng trong các môi trường LAN.

Q-IN-Q là gì

Khi triển khai 802.1Q Tunneling, các khối dữ liệu VLAN được đóng gói bằng thêm một tiêu đề VLAN bổ sung. Điều này tạo ra một lớp “outer VLAN” và một lớp “inner VLAN. Lớp outer VLAN chủ yếu được sử dụng để định tuyến qua mạng truyền trực tiếp, trong khi lớp inner VLAN chứa thông tin VLAN thực sự của người gửi.

Một số ứng dụng thực tế của 802.1Q Tunneling bao gồm việc tạo ra các kết nối mạng ảo giữa các địa điểm khác nhau trong một tổ chức hoặc truyền dữ liệu qua các mạng cơ sở hạ tầng được quản lý bởi các nhà cung cấp dịch vụ.

Trong quá trình hoạt động, switch hỗ trợ 802.1Q Tunneling sẽ thêm thêm một tiêu đề VLAN (Q-in-Q) vào gói tin khi chúng đi qua. Điều này giúp duy trì tính cô lập của các mạng VLAN và tăng khả năng mở rộng của hệ thống mạng.

Hãy nhớ rằng 802.1Q Tunneling đặc biệt hữu ích khi cần truyền tải dữ liệu VLAN qua mạng WAN hoặc giữa các trung tâm dữ liệu có cấu trúc VLAN khác nhau.

Cách Q-IN-Q hoạt động

Để hình dung rõ hơn, ta sẽ đi vào một ví dụ thực tế về cách hoạt động của Q-IN-Q dưới đây:

Q-IN-Q

Ở mô hình trên ta thấy có hai Router (R1 và R2). Bây giờ ta sẽ coi các Router này là trang web của khách hàng mà chúng ta muốn kết nối qua mạng nhà cung cấp dịch vụ (bao gồm 3 Switch: SW1, SW2 và SW3). Khách hàng muốn sử dụng VLAN 12 giữa 2 điểm và nhà cung cáp vận chuyển dữ liệu từ R1 sang R2.

Lúc này ta sẽ sử dụng Q-IN-Q, trong khi R1 và R2 sử dụng VLAN 12 cho lưu lượng trang web thì nhà cung cấp dịch vụ sử dụng VLAN 123 để chuyển tiếp dữ liệu. Hãy xem hình ảnh dưới đây để hiểu rõ phần TAG VLAN trên các khung dữ liệu khi gửi từ R1 tới R2 biến đổi như nào?

ví dụ gắn thẻ tag Q-IN-Q

Theo đó, khi R1 muốn gửi lưu lượng, thẻ TAG VLAN 12 sẽ được thêm vào Frame. Sau đó, khi lưu lượng tới nhà mạng, SW1 sẽ thêm 1 thẻ TAG VLAN 123 bổ sung. Khi SW2 chuyển tiếp dữ liệu thì nó sẽ xóa thẻ TAG bổ sung đi và chuyển tiếp khung gắn thẻ ban đầu từ R1.

Ta có thể thấy rõ sự khác nhau về cấu trúc gói tin được biến đổi trong quá trình Q-IN-Q như sau:

Cách cấu hình Q-IN-Q

Tiếp túc với ví dụ ở trên, bây giờ ta sẽ đi vào cách để cấu hình thực tế trong ví dụ trên như thế nào?

Để cấu hình ta sẽ cần phải thực hiện các việc sau:

  • Định cấu hình VLAN trên R1 và R2.
  • Định cấu hình đường Trunk giữa SW1-SW3 và SW3-SW2
  • Định cấu hình đường hầm Q-IN-Q trên SW1 và SW2 (vì đây là nơi mà thẻ TAG sẽ được thêm vào, nhưng ta cũng phải đảm bảo SW3 có cơ sở dữ liệu VLAN 123).

Cấu hình chi tiết của Router R1 và R2:

R1:

R1(config)#interface fastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#interface fastEthernet 0/0.12
R1(config-subif)#encapsulation dot1Q 12
R1(config-subif)#ip address 192.168.12.1 255.255.255.0

R2:

R2(config)#interface fastEthernet 0/0
R2(config-if)#no shutdown
R2(config-if)#interface fastEthernet 0/0.12
R2(config-subif)#encapsulation dot1Q 12
R2(config-subif)#ip address 192.168.12.2 255.255.255.0

Ở trên ta đã định cấu hình cả 2 bộ định tuyến sử dụng mạng con 192.168.12.0 /24 và gắn TAG VLAN 12 vào các khung dữ liệu của chúng.

Cấu hình đường Trunk giữa các Switch:

SW1:

SW1(config)#interface fastEthernet 0/19
SW1(config-if)#switchport trunk encapsulation dot1q
SW1(config-if)#switchport mode trunk

SW2:

SW2(config)#interface fastEthernet 0/21
SW2(config-if)#switchport trunk encapsulation dot1q
SW2(config-if)#switchport mode trunk

SW3:

SW3(config)#interface fastEthernet 0/19
SW3(config-if)#switchport trunk encapsulation dot1q
SW3(config-if)#switchport mode trunk
SW3(config)#interface fastEthernet 0/21
SW3(config-if)#switchport trunk encapsulation dot1q
SW3(config-if)#switchport mode trunk

Ở trên, ta đã cấu hình các đường Trunk trên các Switch cùng với các giao diện tương ứng.

Cấu hình đường hầm Q-IN-Q:

SW1:

SW1(config)#interface fastEthernet 0/1
SW1(config-if)#switchport access vlan 123
SW1(config-if)#switchport mode dot1q-tunnel

SW2:

SW2(config)#interface fastEthernet 0/2
SW2(config-if)#switchport access vlan 123
SW2(config-if)#switchport mode dot1q-tunnel

SW3:

SW3(config)#vlan 123

Như vậy là ta đã hoàn thành quá trình cấu hình đường hầm Q-IN-Q trong ví dụ trên. Dưới đây là các ý nghĩa lệnh cấu hình bạn cần biết:

  • switchport mode dot1q-tunnel“: Đặt chế độ hoạt động của một cổng trên switch để sử dụng 802.1Q Tunneling (Q-in-Q).
  • switchport access vlan“: Gán một cổng vào một VLAN cụ thể trong chế độ truy cập.
  • switchport trunk encapsulation dot1q“: Xác định giao thức đóng gói cho cổng trunk là 802.1Q
  • switchport mode trunk“: Đặt chế độ hoạt động của cổng thành chế độ trunk.

Sau khi hoàn thành quá trình cấu hình, ta có thể kiểm tra bằng các lệnh “show vlan” và “show interfaces trunk“.

Mong rằng bài viết này đã giúp bạn hiểu rõ về tác dụng của đường hầm Q-IN-Q và cách sử dụng và cấu hình chi tiết như thế nào? Nếu bạn còn có vấn đề cần giải đáp, hãy để lại dưới phần bình luận để được hỗ trợ giải đáp tốt nhất!

Thông Tin Về Tác Giả

Tổng Biên Tập at Thiết Bị Mạng Giá Rẻ | Website | + posts

Nguyễn Thành Hợp là một chuyên gia về lĩnh vực thiết bị mạng, viễn thông gần 10 năm kinh nghiệm với nhiều chứng chỉ chất lượng như CCNA 200-301, CCNP, CCDA, CCDP,... do Cisco cung cấp. Sở thích cá nhân là khám phá những kiến thức mới mẻ về công nghệ nói chung và đặc biệt là liên quan đến lĩnh vực mạng!