Giao thức LACP, hay Link Aggregation Control Protocol, là một tiêu chuẩn giao thức được sử dụng trong mạng máy tính để tạo ra và quản lý nhóm liên kết (link aggregation group) giữa các thiết bị mạng như switch và network interface cards (NICs). Mục tiêu chính của LACP là kết hợp nhiều liên kết vật lý thành một liên kết logic duy nhất để cung cấp băng thông tăng và sự dự phòng.

giao thức LACP

Đặc điểm của giao thức LACP gồm:

  • LACP cho phép nhiều liên kết vật lý hoạt động như một liên kết duy nhất, tăng băng thông sử dụng và cải thiện hiệu suất mạng.
  • Khi một trong các liên kết gặp sự cố, các liên kết khác trong nhóm có thể đảm nhiệm công việc, giảm thiểu tác động của sự cố và duy trì tính sẵn sàng cao của mạng.
  • LACP sử dụng quy trình thương lượng giữa các thiết bị để xác định xem liệu chúng có thể kết hợp thành một nhóm liên kết hay không. Quá trình này đảm bảo sự tương thích giữa các thiết bị tham gia.
  • LACP hỗ trợ sự linh hoạt trong việc thêm mới hoặc loại bỏ các liên kết mà không làm ảnh hưởng đến hoạt động của nhóm liên kết.

Giao thức LACP hoạt động thế nào?

Nguyên tắc hoạt động của LACP dựa trên quá trình thương lượng giữa các thiết bị mạng để tạo ra một nhóm liên kết, còn được gọi là liên kết đồng bộ (aggregate link) hoặc nhóm liên kết (link aggregation group). Dưới đây là mô tả chi tiết về cách LACP hoạt động:

giao thức LACP hoạt động

Để tăng tính dự phòng, giữa 2 Switch ta sẽ lắp nhiều kết nối song song. Khi kích hoạt LACP trên 2 Switch, chúng sẽ gửi gói tin LACPDU để bắt đầu quá trình thương lượng bằng cách xác định mức độ ưu tiên của Switch nào cao hơn?

Switch với mức độ ưu tiên cao hơn sẽ làm Actor trong khi đó Switch thấp hơn sẽ làm Partner. Nếu 2 Switch có cùng mức độ ưu tiên thì Switch nào có địa chỉ MAC nhỏ hơn sẽ làm Actor.

Sau khi đã chọn Actor, các Switch sẽ chọn cổng hoạt động dựa trên mức độ ưu tiên cổng của Actor. Nếu các cổng có cùng mức độ ưu tiên thì số cổng nhỏ hơn sẽ được chọn làm cổng hoạt động.

Lúc này, kênh nhóm liên kết sẽ được thiết lập và các hoạt động truyền dữ liệu cân bằng có thể thực hiện.

Cách LACP tăng băng thông và tính dự phòng

LACP cho phép nhiều liên kết vật lý hoạt động như một liên kết logic duy nhất. Các khối dữ liệu được phân chia và truyền song song qua các liên kết trong nhóm, từ đó tăng tổng băng thông sử dụng. Ví dụ: nếu ta có 2 kết nối 1 Gbps giữa 2 Switch và sử dụng LACP thì ta sẽ có 1 liên kết là 2 Gbps. Tăng băng thông đồng nghĩa với việc truyền dữ liệu tăng nhanh.

Một điều nữa là các gói tin khi truyền qua nhóm liên kết sẽ được chia đều các gói tin cho các liên kết trong nhóm. Điều này tránh việc quá tải trên một liên kết cụ thể.

Khi có liên kết mới được thêm vào hoặc loải bỏ khỏi nhóm liên kết thì hoạt động của nhóm vẫn được duy trì mà không bị gián đoạn. Khi một liên kết trong nhóm gặp sự cố, LACP có khả năng chuyển giao công việc sang các liên kết khác trong nhóm.

LACP liên tục giám sát trạng thái của các liên kết trong nhóm. Nó cung cấp khả năng phục hồi nhanh chóng khi một liên kết trở lại trạng thái hoạt động bình thường.

Chế độ hoạt động của LACP

Chế độ LACP

Giao thức LACP hoạt động trong hai chế độ cơ bản là “Active” và “Passive”. Dưới đây là mô tả chi tiết về cả hai chế độ này:

1. Chế độ Active

Trong chế độ này, thiết bị mạng gửi các tin nhắn LACP có chứa thông tin về khả năng của mình và mong muốn tạo thành một nhóm liên kết. Thiết bị ở chế độ Active chủ động kích thích quá trình thương lượng và quyết định xem liệu nó có thể hình thành một nhóm liên kết với thiết bị kia hay không. Nếu cả hai thiết bị đều ở chế độ Active và đều đồng ý, quá trình kết hợp liên kết sẽ được khởi tạo.

2. Chế độ Passive

Thiết bị ở chế độ Passive chỉ đơn giản chấp nhận thông điệp thương lượng từ thiết bị Active mà không gửi thông điệp thương lượng chủ động. Nó chờ đợi thông điệp từ thiết bị Active và phản hồi nếu nó đồng ý với các điều kiện thương lượng được đề xuất.

Cấu hình LACP

Để định cấu hình LACP, ít nhất phải có một thiết bị ở chế độ Active. Ta sẽ đi vào ví dụ trực tiếp cấu hình LACP giữa 2 Switch với các thông tin như sau:

  • Switch 1 cấu hình ở chế độ Active với 2 giao diện kết nối là Fa0/1 va Fa0/2.
  • Switch 2 cấu hình ở chế độ Passive với 2 giao diện kết nối là Fa0/1 và Fa0/2.

Bạn có thể xem hình ảnh mô tả minh họa cấu trúc vật lý giữa 2 Switch như sau:

ví dụ cấu hình LACP

Dưới đây là cấu hình chi tiết:

Switch 1:

Switch1# configure terminal
Switch1(config)# interface range FastEthernet0/1 - 2
Switch1(config-if-range)# channel-group 1 mode active
Switch1(config-if-range)# exit
Switch1(config)# interface Port-channel 1
Switch1(config-if)# switchport mode trunk
Switch1(config-if)# exit
Switch1(config)# end
Switch1# write memory

Switch 2:

Switch2# configure terminal
Switch2(config)# interface range FastEthernet0/1 - 2
Switch2(config-if-range)# channel-group 1 mode passive
Switch2(config-if-range)# exit
Switch2(config)# interface Port-channel 1
Switch2(config-if)# switchport mode trunk
Switch2(config-if)# exit
Switch2(config)# end
Switch2# write memory

Giải thích cấu hình:

  • interface range FastEthernet0/1 – 2: Chọn các cổng FastEthernet 0/1 và 0/2 để cấu hình.
  • channel-group 1 mode active: Đặt cổng vào một nhóm liên kết (Port-channel 1) ở chế độ Active.
  • interface Port-channel 1: Chuyển sang cấu hình trên Port-channel 1.
  • switchport mode trunk: Thiết lập chế độ trunk trên Port-channel để có thể chuyển đủ các VLAN.

Ứng dụng LACP

  1. Data Centers và Server Farms: Sử dụng LACP để kết hợp nhiều liên kết giữa server và switch, tối ưu hóa băng thông cho việc truyền tải dữ liệu giữa server và mạng.
  2. Mạng doanh nghiệp : Trong môi trường doanh nghiệp, LACP giúp tăng băng thông và cung cấp sự dự phòng, đảm bảo tính ổn định của mạng.
  3. Kết nối giữa các trung tâm dữ liệu: Sử dụng LACP để kết hợp liên kết giữa các trung tâm dữ liệu, tạo ra kết nối mạng mạnh mẽ và đáng tin cậy.
  4. VoIP và Video Conferencing: Tối ưu hóa băng thông giữa các thiết bị trong môi trường VoIP và video conferencing, giảm độ trễ và đảm bảo trải nghiệm người dùng tốt nhất.

So sánh LACP và LAG

LACPLAG (Link Aggregation Group) đều liên quan đến việc kết hợp nhiều liên kết vật lý thành một liên kết logic để tăng băng thông và cung cấp tính sẵn sàng cao trong mạng. Tuy nhiên, chúng khác nhau về mục đích và triển khai.

LACP là một giao thức được sử dụng để thương lượng và quản lý quá trình kết hợp liên kết, chủ yếu tập trung vào việc xác định khả năng hình thành một nhóm liên kết giữa các thiết bị trong mạng. Nó hoạt động trong hai chế độ là Active và Passive, quản lý quá trình thương lượng giữa chúng.

Ngược lại, LAG là một khái niệm mô tả việc tạo ra một liên kết logic từ nhiều liên kết vật lý, không phải là một giao thức. LAG có thể được triển khai với nhiều giao thức khác nhau như LACP, PAgP, hoặc cấu hình tĩnh.

Thông Tin Về Tác Giả

Tổng Biên Tập at Thiết Bị Mạng Giá Rẻ | Website | + posts

Nguyễn Thành Hợp là một chuyên gia về lĩnh vực thiết bị mạng, viễn thông gần 10 năm kinh nghiệm với nhiều chứng chỉ chất lượng như CCNA 200-301, CCNP, CCDA, CCDP,... do Cisco cung cấp. Sở thích cá nhân là khám phá những kiến thức mới mẻ về công nghệ nói chung và đặc biệt là liên quan đến lĩnh vực mạng!